Snapshots now ran every 12 hours

Hey folks:

I’ve now merged a pull request that will update snapshots every 24 hours.

Those snapshots are still published to OSS sonatype. Sorry it took so long.
We were migrating to github actions. There’s still more work to do yet.
A release based on our new github actions infra will be coming hopefully next week.
Feel free to comment here with any questions.

Hey @agibsonccc,
I noticed that the nd4j-native jar (without linux x86 flag) contains .so files, which were not there before. And conversely: nd4j-native-linux-x86_64 jar file consists of config files and no shared libraries, unlike before.
Is this part of the new ci/cd changes?

Thanks @pza94 let me look in to this. I had other reports just now. Let me look in to github actions a bit to see what’s going on. I’ll rerun the builds ASAP.

Snapshots should now be properly setup. For anyone else, please feel free to report any issues. If you’ve downloaded snapshots recently, please run mvn with a -U flag to reupdate your local dependencies.

Hello @agibsonccc,

https://oss.sonatype.org/service/local/artifact/maven/redirect?r=snapshots&g=org.nd4j&a=nd4j-native&v=1.0.0-SNAPSHOT&e=jar&c=android-arm64

nd4j-native android-arm64 jar is missing. If I understand correctly it should be there now or it is somewhere else?

@lavajaw snapshots for android-arm64 are still WIP yet. Arm32 might work today. Still some linker issues to sort out yet. That’s the last build I need to get working before final testing.

@lavajaw arm64 builds are published now. Please let me know how it goes.

I got error:
java.lang.ExceptionInInitializerError
at org.nd4j.nativeblas.NativeOpsHolder.getInstance(NativeOpsHolder.java:123)
at org.nd4j.linalg.cpu.nativecpu.ops.NativeOpExecutioner.(NativeOpExecutioner.java:78)
at java.lang.Class.newInstance(Native Method)

couldn’t find “libjnind4jcpu.so”
couldn’t find “libnd4jcpu.so”

Because gradle has problem with snapshots:

I tried solution described on that example and also tried to add .jar to libs folder but no luck. :frowning:

@lavajaw thanks for trying. Mind DMing me more details?
Edit: @lavajaw just looking at it, the libn4j binaries for android-arm64 are here:
https://oss.sonatype.org/content/repositories/snapshots/org/nd4j/libnd4j/1.0.0-SNAPSHOT/
The jar here: Index of /repositories/snapshots/org/nd4j/nd4j-native/1.0.0-SNAPSHOT
(android-arm64) also seems to be fine. I’m going to be doing some dedicated testing on android today (using lineageos) so I’ll try to reproduce some of the issues you’re mentioning.